当前位置:首页 > 技术分享

swoole启动报错:failed to listen server port[0.0.0.0:9501], Error: Address already

admin4年前 (2022-11-03)技术分享5237

出现 failed to listen server port[0.0.0.0:9501], Error: Address already in use[98]这个错误就是说明你的Hyperf启动端口被占用了。

处理方式:

要么换一个;

要么kill掉这个占用的端口;  

在重新启动就ok了

复现报错代码:

                                                               
  failed to listen server port[0.0.0.0:9501], Error: Address already in use[98]  
       


处理步骤:

1.查看端口上的进程pid号

netstat -anp | grep 9501
tcp        0      0 0.0.0.0:9501            0.0.0.0:*               LISTEN      20852/skeleton.Mast 

2.根据上面查看到的进程号kill掉

kill -9 20852

3.杀死后 在看看占用端口没有了

netstat -anp | grep 9501


扫描二维码推送至手机访问。

版权声明:本文由小刚刚技术博客发布,如需转载请注明出处。

本文链接:https://blog.bitefu.net/post/444.html

标签: swoole
分享给朋友:

“swoole启动报错:failed to listen server port[0.0.0.0:9501], Error: Address already” 的相关文章

centos 配置Let's Encrypt 泛域名https证书

centos 配置Let's Encrypt 泛域名https证书

前言2018年1月份Letsencrypt可以申请泛域名证书,这让我们部署多域名、多站点https省了很多功夫,终于可以不用维护多个域名的https证书。笔者以acme.sh为例,手把手教你配置https证书~本教程适用于centos 6.…

python 高速处理分析超大网站日志文件 带进度条手动输入日志文件

 python 高速处理分析超大网站日志文件 带进度条手动输入日志文件    1 统计本日志文件的总pv、uv    2 列出全天每小时的pv、uv数    3 列出to…

[教程福利] Python 全网比较全面的资源

阿里 Python 应该算比较全面了,编辑完了差不多用了三个小时左右,如果对你有帮助,给个免费的热心吗,在这里谢谢了各位大佬。092-****实战课-畅销3年的Python分布式爬虫课程-原版提取https://www.aliyundriv…

Linux/centos inode 占用100%的解决办法

当你的 Linux 系统无法创建新文件时,有可能是你的磁盘满了,还有可能是你的磁盘的 inode 用光了,我们今天要说的就是后一种情况,要解决这个问题,只能是删除一些文件,但是一般情况下,其实是你的系统中的某个地方产生了大量的你并不需要的文…

全世界最快dns分享 Public DNS Server List

偶然发现一个共享全世界最快dns的网站,当然也包含中国了https://public-dns.info/ 中国https://public-dns.info/nameserver/cn.html…

redis 设置过期Key 的 maxmemory-policy 六种方式

平时会用到redis 当缓存过多时会遇到下面的报错OOM command not allowed when used memory > 'maxmemory'这说明redis的缓存满了我们可以通过修改过期策略来修改cd…

发表评论

访客

看不清,换一张

◎欢迎参与讨论,请在这里发表您的看法和观点。